Cloudflare related outage with Simpplr

Incident Report for Simpplr One

Resolved

Hello,
Cloudflare has resolved the issues related to their maintenance and elevated error rates. Simpplr functionality has fully stabilized, and no further impact is expected.

Thank you for your patience.
Simpplr Technical Support
Posted Dec 05, 2025 - 13:11 UTC

Investigating

Hello,
Cloudflare has announced active scheduled maintenance across select datacenters (ORD – Chicago and DTW – Detroit) and is also investigating an increased level of errors impacting Cloudflare Workers and the Workers KV API. These issues may cause intermittent disruptions within Simpplr, including slower load times, temporary errors, or occasional empty responses in areas that rely on Cloudflare services.

We are closely monitoring Cloudflare’s status updates and will continue to track the impact to Simpplr. Cloudflare is actively working to resolve the errors and complete their maintenance activities.

Thank you for your patience as we monitor and respond to these upstream issues.

Simpplr Technical Support
Posted Dec 05, 2025 - 09:54 UTC
This incident affected: System.