Microsoft has resolved the service degradation affecting Outlook and Microsoft 365. Simpplr email functionality is now operating normally, and no further impact is expected.
Thank you for your patience. Simpplr Technical Support
Posted Jan 23, 2026 - 07:44 UTC
Monitoring
Hello,
We have verified that previously undelivered newsletters are now being delivered to Outlook users in some time intervals. However, some delivery delays are still being observed due to the ongoing Microsoft service degradation.
We are still actively monitoring the issue and the Microsoft status page and will continue to share updates as needed.
Thank you for your continued patience and understanding, Simpplr Technical Support Team
Posted Jan 23, 2026 - 05:15 UTC
Identified
Microsoft is reporting that a number of services, including Outlook and Microsoft 365, are experiencing degradation and outages. If your organization uses Outlook or other Microsoft services for email, newsletters and other emails may be delayed or not delivered.