Analytics dashboard intermittent failure to load

Incident Report for Simpplr One

Resolved

Hello,

The issue causing delays in analytics dashboards has been resolved. Our vendor identified that performance was being impacted by how historical data was handled and has implemented backend optimizations to improve data processing. As a result, dashboards are now performing as expected.

We’ll continue to monitor the system and work closely with the vendor to ensure long-term stability. Thank you for your continued patience and understanding.

Best regards,
Simpplr Technical Support
Posted May 14, 2025 - 20:26 UTC

Update

Hi there,
We’d like to share an update on the ongoing issue impacting analytics dashboards. While dashboards are currently usable, users may continue to experience delays in data loading.

Our engineering team is actively working to implement a long-term fix and fully resolve the issue. We understand how disruptive this has been and sincerely appreciate your patience as we continue to make progress.

We’ll keep you updated with any significant developments.

Thank you,
Simpplr Technical Support
Posted May 14, 2025 - 15:06 UTC

Identified

Hello there,
We’re currently working to resolve an issue causing delays in analytics dashboards. Our engineering team is actively investigating to identify the root cause and implement a long-term fix.

We’re aware that similar issues have occurred recently and understand how disruptive this can be. We sincerely appreciate your patience as we work to address the issue and prevent future occurrences.

Thank you,
Simpplr Technical Support
Posted May 13, 2025 - 14:49 UTC
This incident affected: Analytics.